RMIS TX and CA Carrier Data
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Dec 06, 2024 - 11:58 MST
Investigating
We are aware that currently TX and CA intrastate carrier authority data is not up to date in RMIS. The team is working to resolve quickly.
Posted Dec 06, 2024 - 11:04 MST
This incident affected: COMPLIANCE (RMIS).