Truckstop Email Delay
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 13:49 MST
Investigating
We are aware of an ongoing issue with our email vendor, resulting in delays in the receipt and potential quarantine of emails for Truckstop users with Office365 accounts. Our vendor is actively working on a resolution. We apologize for any inconvenience and are working with the vendor to resolve this as quickly as possible.
Posted Feb 06, 2024 - 11:36 MST