Onboarding Error
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Mar 11, 2024 - 11:51 MDT
Investigating
Customers are currently encountering an error when selecting or attempting to upload documents in the Onboarding process. Our team is aware and working to resolve the issue as quickly as possible.
Posted Mar 11, 2024 - 11:28 MDT
This incident affected: COMPLIANCE (Onboarding).