Load Board Issues

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 16:04 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2026 - 15:55 MST

Investigating

We are aware that customers could be experiencing issues with the Load Board. The team is actively investigating and working to resolve as quickly as possible.
Posted Feb 04, 2026 - 15:53 MST
This incident affected: FREIGHT (Loadboard, Mobile).