ITS Dispatch / SaferWatch API Issues

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 08:38 MDT

Investigating

We are currently investigating reports of issues with the SaferWatch API that may prevent customers from assigning carriers in ITS Dispatch. Our team is working to resolve the issue and will provide updates as they become available.
Posted Aug 21, 2025 - 08:12 MDT
This incident affected: TMS (ITS Dispatch) and COMPLIANCE (SaferWatch).