Delays with Load Search & Post

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 11:52 MST

Investigating

Due to a vendor issue, some loads may not appear in the load grid, and users may experience slowness when searching for or posting loads. Our team is actively working with the vendor to resolve the issue as quickly as possible.
Posted Jan 12, 2026 - 10:13 MST
This incident affected: FREIGHT (Loadboard, Mobile).