Saferwatch Alert Delays

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 09:31 MDT

Investigating

We are aware of FMCSA Data Delays causing delays in SaferWatch alerts and related emails. Our system is currently processing the data, and updates will be sent as soon as they are available.
Posted Apr 03, 2025 - 09:00 MDT
This incident affected: COMPLIANCE (SaferWatch).