Load Board Login Errors
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Feb 07, 2024 - 19:17 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2024 - 17:22 MST
Investigating
We are aware some customers are experiencing error messages when attempting to log in to the Load Board. Our team is aware of the issue and is working diligently to resolve.
Posted Feb 07, 2024 - 15:50 MST
This incident affected: FREIGHT (Loadboard).