Truck Posting Issue

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 10:03 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 11, 2026 - 08:52 MDT

Investigating

We are investigating reports of some customers experiencing issues when accessing Truck Posting. Affected users may encounter a blank white screen, delayed page loading, or difficulty completing the truck post. The team is working to resolve this as soon as possible
Posted Aug 11, 2026 - 08:43 MDT
This incident affected: FREIGHT (Loadboard).