Load Posting Issue

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 13:46 MDT

Investigating

We are aware there is currently an issue and some customers might be unable to select the "More Load Options" when posting a load. The team is investigating and looking to resolve as quickly as possible.
Posted Aug 27, 2026 - 11:03 MDT
This incident affected: FREIGHT (Loadboard).