Load Board Menu Items

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 08:13 MDT

Identified

The issue has been identified and a fix has been implemented. If you are still experiencing issues, a hard refresh (Ctrl + F5) will help resolve the issue in most cases
Posted Aug 13, 2026 - 07:30 MDT

Investigating

We are investigating reports of some customers experiencing issues accessing load board menu items. The team is working to resolve this as soon as possible.
Posted Aug 13, 2026 - 07:19 MDT
This incident affected: FREIGHT (Loadboard).