ITS Dispatch - Document Upload
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Feb 12, 2024 - 21:20 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2024 - 14:28 MST
Investigating
We are aware that customers uploading documents in ITS Dispatch are current seeing them stay in "pending" status. The team is aware and working to resolve as quickly as possible.
Posted Feb 12, 2024 - 10:31 MST
This incident affected: TMS (ITS Dispatch).