Load Search Issues

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 08:26 MDT

Investigating

We are aware that load searches may not be working on the load board for some customers. Our team is working to resolve this as quickly as possible.
Posted Mar 27, 2025 - 08:01 MDT
This incident affected: FREIGHT (Loadboard).