ITSD log in cache

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted May 05, 2026 - 11:55 MDT

Update

We are aware that some customers may be experiencing issues logging into ITSD. If you are experiencing an issue, please clear your cache and cookies and retry. For steps on how to do this, please visit: https://community.truckstop.com/s/article/Clearing-cache-in-cookies-for-ITS-Dispatch.
Posted Apr 29, 2026 - 10:51 MDT

Identified

We are aware that some customers may be experiencing issues logging into ITSD. If you are experiencing an issue, please clear your cache and cookies and retry.
Posted Apr 28, 2026 - 07:43 MDT
This incident affected: TMS (ITS Dispatch).