RMIS TIN Matching Delay

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 09:14 MST

Investigating

The IRS is running slow causing intermittent issues with customers verifying the carriers TIN matching in RMIS.
Posted Feb 18, 2026 - 16:51 MST
This incident affected: COMPLIANCE (RMIS).