Resolved - Load Search Error
Incident Report for Truckstop
Resolved
This error has been resolved.
Posted Nov 18, 2022 - 08:13 MST
Investigating
Some customers are receiving an error when attempting to search for a load or truck post. The team is aware of the issue and is working to resolve as quickly as possible.
Posted Nov 18, 2022 - 07:10 MST
This incident affected: FREIGHT (Loadboard).