FMCSA Data Update Delay
Incident Report for Truckstop
Resolved
Risk Factors, Saferwatch and RMIS are up to date with all files. Service has been restored, and this incident has been resolved.
Posted Dec 18, 2024 - 08:52 MST
Update
We are continuing to monitor for any further issues.
Posted Dec 12, 2024 - 09:49 MST
Update
We are continuing to monitor for any further issues.
Posted Dec 12, 2024 - 09:22 MST
Monitoring
FMCSA has reported the following update: L&I data will return to its prior delivery format. The next anticipated delivery of this data is scheduled for December 20, 2024.

We will continue to keep our customers updated as FMCSA addresses these delays.
Posted Dec 11, 2024 - 13:37 MST
Investigating
We are aware that some customers are experiencing delays in receiving updated Licensing & Insurance data in SaferWatch and RMIS due to FMCSA not updating its data since December 8, 2024. Our team is monitoring the situation and is ready to process new FMCSA data as soon as it becomes available.
Posted Dec 10, 2024 - 09:27 MST
This incident affected: COMPLIANCE (RMIS, SaferWatch) and FREIGHT (Risk Factors).