Load Post Error

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted May 27, 2025 - 08:45 MDT

Investigating

We are aware that some customers may be experiencing issues with posting loads via integration to the Loadboard. Our team is actively working to resolve this issue.
Posted May 22, 2025 - 09:07 MDT
This incident affected: FREIGHT (Loadboard).