Load Board Incidents

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted May 14, 2026 - 15:17 MDT

Investigating

We are aware that some menu items are not available in the Load Board such as Load Manager and Truck Posting. The team is actively working to resolve.
Posted May 14, 2026 - 14:35 MDT
This incident affected: FREIGHT (Loadboard).