Saferwatch Alert & Email Notifications Delayed

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 11:08 MDT

Investigating

Due to delays in receiving the FMCSA data, customers who are signed up for Saferwatch alerts and marketing emails will be delayed. Our system is currently processing the data, and updates will be sent as soon as they are available.
Posted Jul 02, 2025 - 08:47 MDT
This incident affected: COMPLIANCE (SaferWatch).