Load Posting Issue

Incident Report for Truckstop

Identified

The issue has been identified and a fix is being implemented. New loads may still have a delay in posting.
Posted Dec 04, 2025 - 12:55 MST

Investigating

We are aware of an issue that load postings are delayed or not showing up on the load board or in search. The team is actively investigating to fix as quickly as possible.
Posted Dec 04, 2025 - 10:38 MST
This incident affects: FREIGHT (Loadboard).