The planned ingestion for the FMCSA Census changes are complete.
Posted Aug 24, 2026 - 11:50 MDT
Identified
FMCSA has released a new Census file that retains the changes made earlier this week. Beginning at 5pm MT today, we're processing that update to keep our data in sync with FMCSA's. You can expect an unusually high volume of carrier changes, with elevated activity continuing through the weekend. Depending on your business rules, some carriers may be decertified. No action is needed on your part.
Posted Aug 21, 2026 - 15:12 MDT
Investigating
For RMIS Customers: We've identified an unusually large number of changes in yesterday's Motus file, including some that appear unintentional — for example, a large number of records where data in a specific field is now blank. As a result, we've paused ingestion of Census data while we investigate. We are in contact with the FMCSA to confirm whether these changes are accurate. They've confirmed they're investigating on their end as well. We'll continue to post updates as we learn more.