Truck Management Unavailable

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 15:45 MDT

Investigating

We are investigating an issue affecting Truck Management. Customers may be unable to post, update, or remove truck availability, and search results may not reflect the most recent posted capacity. We are working to restore service as quickly as possible.
Posted Jun 29, 2026 - 14:52 MDT
This incident affected: FREIGHT (Loadboard, Mobile).