QuickBooks Processing Delay
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 15:53 MST
Investigating
We are currently experiencing a delay in QuickBooks due to a recent software update. Rest assured, all ACH payments will be processed today as planned. However, please be aware that funding may not appear in your account until tomorrow morning. We appreciate your patience as we work through this issue and ensure that your payments reach you as quickly as possible.
Posted Nov 06, 2024 - 11:12 MST
This incident affected: PAYMENTS (Factoring).