Load Manager Error

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 12:29 MST

Investigating

We are aware that customers may receive an error message stating it is unable to retrieve your list of loads in Load Manager. The team is actively working to resolve this issue.
Posted Feb 03, 2026 - 12:04 MST
This incident affected: FREIGHT (Loadboard).