Fuel Desk and Load Details Delays
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 07:15 MST
Investigating
We are aware that some customers are experiencing slowness when using the Fuel Desk and Load Details summary features due to a vendor issue. The team is working with the vendor to resolve this issue as quickly as possible.
Posted Nov 19, 2024 - 11:07 MST
This incident affected: FREIGHT (Loadboard, Mobile).