Load Post Error

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 13:52 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 13:04 MDT

Investigating

We are aware that customers are unable to post loads. The team is actively investigating and we apologize for any inconvenience.
Posted Apr 30, 2026 - 13:00 MDT
This incident affected: FREIGHT (Loadboard).