Rate Insights

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted May 07, 2026 - 17:02 MDT

Investigating

We are aware that Rate Insights is not populating on the load board. The team is investigating and working to resolve as quickly as possible.
Posted May 07, 2026 - 14:51 MDT
This incident affected: RATES (Rate Insights).