Load Board Log In Error

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 11:16 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2025 - 08:28 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2025 - 07:41 MDT

Monitoring

If the error persists, try the following steps to resolve the error:
- Clear cache & cookies for "All time" (not just 24hrs, 7 days etc)
- Close browser windows
- Login via Truckstop.com --> Login --> Load Board (instead of using a bookmarked/favorited page)
Posted Jul 02, 2025 - 07:20 MDT

Investigating

We are aware that some customers are receiving an error message when trying to log into the load board. The team is actively working to resolve as quickly as possible.
Posted Jul 02, 2025 - 06:49 MDT
This incident affected: FREIGHT (Loadboard, Mobile).