Hot Prospects Tool Delay

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 17:55 MDT

Investigating

We’re aware that some customers may encounter delays or a spinning wheel when attempting to use the Hot Prospects tool in the Load Board. Our team is actively working to resolve the issue and will provide updates as soon as possible.
Posted Jun 02, 2025 - 08:06 MDT
This incident affected: FREIGHT (Loadboard).