Load Post Error
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 20:48 MDT
Investigating
We are aware that some customers may see errors when posting loads from the LoadBoard webpage. Our team is actively working to resolve this issue.
Posted Jul 17, 2024 - 20:32 MDT
This incident affected: FREIGHT (Loadboard).