Load Board Vendor Outage

Incident Report for Truckstop

Update

We are aware that this issue has escalated so that some customers may receive an Error 50 message when attempting to login to our products. We are continuing to work with the vendor to resolve the issue as quickly as possible.
Posted Jun 10, 2025 - 13:57 MDT

Investigating

Due to a vendor outage, we are currently unable to update customer accounts including new users, purchasing new services, or suspending/cancelling accounts. We are working with the vendor to resolve as quickly as possible.

Customer log-in or usage of the load board is not impacted by this outage.
Posted Jun 10, 2025 - 08:10 MDT
This incident affects: FREIGHT (Loadboard, Mobile).