Load Board and Load Posting Delay
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 10:45 MDT
Monitoring
A fix has been implemented and we are monitoring results.
Posted Apr 17, 2024 - 09:14 MDT
Investigating
We are aware that customers are currently experiencing slowness while using the load board and delays in loads posting. We are working to resolve as quickly as possible.
Posted Apr 17, 2024 - 06:44 MDT
This incident affected: FREIGHT (Loadboard, Mobile).