Load Board Issues

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 14:56 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2026 - 10:33 MDT

Investigating

We are aware that some customers might be experiencing intermittent issues with load board menu items and load management functionality. We are working to resolve as quickly as possible.
Posted Jun 29, 2026 - 10:06 MDT
This incident affected: FREIGHT (Loadboard, Mobile).