Freight Matching services unavailable
Incident Report for Truckstop
Resolved
This incident has been resolved
Posted Mar 10, 2024 - 04:46 MDT
Monitoring
A Fix has been applied and we are monitoring that services are now available
Posted Mar 10, 2024 - 03:53 MDT
Identified
We are aware of an issue preventing customers from accessing Truckstop.com from the web. Mobile services are available as a workaround for many services. The team is working to restore services as quickly as possible
Posted Mar 10, 2024 - 01:40 MST
This incident affected: FREIGHT (Loadboard).