Saved Loads (Mobile only)

Incident Report for Truckstop

Resolved

A fix has been implemented. If you continue to not see the Saved Loads menu, please try closing and restarting the app.
Posted Jul 14, 2026 - 11:14 MDT

Investigating

We are aware that some customers may not have the Saved Loads button available on mobile. We are working to fix as soon as possible.
Posted Jul 13, 2026 - 15:12 MDT
This incident affected: FREIGHT (Mobile).