Load Search Slowness
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 11:21 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2024 - 10:38 MDT
Investigating
We are aware that customers are currently experiencing slowness while performing load searches. We are investigating and actively working to restore services as quickly as possible.
Posted Mar 28, 2024 - 06:50 MDT
This incident affected: FREIGHT (Loadboard, Mobile).