Load Post and Search

Incident Report for Truckstop

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 13:04 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2025 - 10:28 MDT

Investigating

Our team is aware that some customers may experience intermittent issues when searching for or posting loads. We are actively working to resolve the issue
Posted Mar 18, 2025 - 09:24 MDT
This incident affected: FREIGHT (Loadboard).