Load Board Error Message on Load Manager
Incident Report for Truckstop
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 16:24 MDT
Investigating
We are aware customers experiencing an error message when accessing the Load Manager. Clicking "ok" on the error will allow you to still post loads and these will show in load searches. Our team is working diligently to resolve this as quickly as possible.
Posted Jul 28, 2022 - 16:11 MDT
This incident affected: FREIGHT (Loadboard).